Toolfarm
final cut pro 10.6.6.png

If you’re updating to Final Cut Pro 10.6.6, a couple of our vendors have issued notes about it. FxPlug, the API that Apple uses for plugins for Final Cut Pro and Motion has been updated to version 4.

This will affect any older plugins so be aware of this if you need to open older projects.

Coremelt

From the Coremelt blog: Final Cut Pro plugins use an API called FxPlug which has been updated in several major versions, the latest version is FxPlug 4. Final Cut Pro 10.6.6 removes the ability to run FxPlug3 plugins on Intel Macs or using Rosetta 2. Although the current products we sell are all available in FxPlug 4 versions this may impact your ability to load old projects.

Projects using Chromatic or the V2 Plugin set cannot be loaded with FCP 10.6.6 or later on Intel or Apple Silicon Macs by any means.

Projects using older versions of our other products before version 4 cannot be loaded with FCP 10.6.6 or later on Intel or Apple Silicon Macs by any means.

FilmConvert

Following the release of Final Cut Pro 10.6.6, FilmConvert Pro and FilmConvert Nitrate plugins built against FxPlug 2, will no longer work. That means:

    FilmConvert Pro v2.5 and older will no longer work in FCP 10.6.6.
    FilmConvert Nitrate 3.06 and older will no longer work in FCP 10.6.6.

If you are using FilmConvert Pro v2.5 or older, please download this compatibility build here to continue using your plugin.

If you are using FilmConvert Nitrate v3.06 or older, please download the latest version of the plugin from here.

If you are still having issues with your version of the plugin, please contact FilmConvert at support@filmconvert.com.

LEAVE A REPLY

Please enter your comment!
Please enter your name here